Bumping CMake

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Bumping CMake

Toby Smithe-2
Hi all,

We need a simple change along the lines of

-CMAKE_MINIMUM_REQUIRED(VERSION 2.4.6)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6.0)

in mscore/CMakeLists.txt, otherwise the build process dies cryptically
with the error,

"""
Unknown CMake command "cmake_policy".
"""


If you are still running Ubuntu 8.04, and are using my prerelease PPA,
then you'll notice you're getting upgrades for qt4-x11, phonon,
automoc and cmake: this shows how relatively ancient that distribution
is. If you're running Ubuntu 8.10, an upgrade for qt4-x11 is on your
way, to bump the version to 4.5.0. I have also updated the build
dependency in the mscore package to require Qt 4.5 or greater.

With these changes, the scripting framework is now fully statically
built, and isn't functionally crippled as before. This means, for
example, that plugins can assume that GUI functionality is alive and
kicking. I hope that this will remain the state for the next stable
release, and will thus be included in the next Ubuntu and Debian
distributions.

Thanks and have fun!,

--
Toby Smithe :: http://fulltinreality.com

------------------------------------------------------------------------------
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
_______________________________________________
Mscore-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mscore-developer
Reply | Threaded
Open this post in threaded view
|

Re: Bumping CMake

wschweer
Administrator
I changed the cmake minimum version in rev. 1640. I would also like to
raise the minimum qt version to qt 4.5 but i am not sure this is already
available for all platforms.

Werner

On Tuesday 17 March 2009 22:45:13 Toby Smithe wrote:

> Hi all,
>
> We need a simple change along the lines of
>
> -CMAKE_MINIMUM_REQUIRED(VERSION 2.4.6)
> +CMAKE_MINIMUM_REQUIRED(VERSION 2.6.0)
>
> in mscore/CMakeLists.txt, otherwise the build process dies cryptically
> with the error,
>
> """
> Unknown CMake command "cmake_policy".
> """
>
>
> If you are still running Ubuntu 8.04, and are using my prerelease PPA,
> then you'll notice you're getting upgrades for qt4-x11, phonon,
> automoc and cmake: this shows how relatively ancient that distribution
> is. If you're running Ubuntu 8.10, an upgrade for qt4-x11 is on your
> way, to bump the version to 4.5.0. I have also updated the build
> dependency in the mscore package to require Qt 4.5 or greater.
>
> With these changes, the scripting framework is now fully statically
> built, and isn't functionally crippled as before. This means, for
> example, that plugins can assume that GUI functionality is alive and
> kicking. I hope that this will remain the state for the next stable
> release, and will thus be included in the next Ubuntu and Debian
> distributions.
>
> Thanks and have fun!,


------------------------------------------------------------------------------
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
_______________________________________________
Mscore-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mscore-developer
Reply | Threaded
Open this post in threaded view
|

Re: Bumping CMake

Toby Smithe-2
2009/3/17 Werner Schweer <[hidden email]>:
> I changed the cmake minimum version in rev. 1640. I would also like to
> raise the minimum qt version to qt 4.5 but i am not sure this is already
> available for all platforms.

Well, as I say, I have already made this change on Ubuntu. We need to
decide which platforms we officially support. If we choose now, we can
choose only those that have Qt 4.5 available ;)

As far as I am aware, we provide a set of sources that runs on any
Linux/X11 system, Windows or Mac OS X, and binary packages for
Windows, potentially Mac OS X, and Ubuntu. All of these have Qt 4.5,
and if a user decides to build from source, then it's even easier to
ensure that Qt 4.5 is available. This would suggest to me that there
would be no loss in raising the minimum Qt version to that.

Have I missed any platforms? Fedora? openSUSE? BSD?

--
Toby Smithe :: http://fulltinreality.com

------------------------------------------------------------------------------
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
_______________________________________________
Mscore-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mscore-developer
Reply | Threaded
Open this post in threaded view
|

Re: Bumping CMake

Luis Garrido-4
Fedora 10 officially packs Qt 4.4
OpenSUSE officially packs Qt 4.4
Debian stable officially packs Qt 4.4
CentOS 5 (RHEL 5) officially packs Qt 4.2

Qt 4.5 was officially released one week ago!

If you jump to 4.5 now you are forcing users to seek alternative
repositories or build Qt from source.

Stability is also an issue. 4.5 is not well tested yet, neither are
the packages built from it.

My 2 cents,

Luis

------------------------------------------------------------------------------
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
_______________________________________________
Mscore-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mscore-developer
Reply | Threaded
Open this post in threaded view
|

Re: Bumping CMake

Toby Smithe-2
2009/3/18 Luis Garrido <[hidden email]>:

> Fedora 10 officially packs Qt 4.4
> OpenSUSE officially packs Qt 4.4
> Debian stable officially packs Qt 4.4
> CentOS 5 (RHEL 5) officially packs Qt 4.2
>
> Qt 4.5 was officially released one week ago!
>
> If you jump to 4.5 now you are forcing users to seek alternative
> repositories or build Qt from source.
>
> Stability is also an issue. 4.5 is not well tested yet, neither are
> the packages built from it.

Hmm. Clearly my sense of time is a little distorted. In this case, I
would advocate keeping the current requirement until at least after
the the next release(s) of Fedora and/or openSUSE; I don't think
Debian will be releasing squeeze for a while.

--
Toby Smithe :: http://fulltinreality.com

------------------------------------------------------------------------------
Apps built with the Adobe(R) Flex(R) framework and Flex Builder(TM) are
powering Web 2.0 with engaging, cross-platform capabilities. Quickly and
easily build your RIAs with Flex Builder, the Eclipse(TM)based development
software that enables intelligent coding and step-through debugging.
Download the free 60 day trial. http://p.sf.net/sfu/www-adobe-com
_______________________________________________
Mscore-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mscore-developer