strange error compiling/running musescore

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

strange error compiling/running musescore

Jim Newton
I'm compiling and running musescore from xcode, so admittedly I don't 100% understand which messages occur at compile time vs runtime.  But I get the following errors very often.  I don't think it is serious because everything seems to work fine.  But can someone shed light on what the problems are, what's causing are, and what I might to to fix them?

initScoreFonts 0x1084536d0
in stat: : No such file or directory
in stat: : No such file or directory
in stat: : No such file or directory
in stat: : No such file or directory
Init midi driver failed
init Help from: </Users/jimka/MuseScore/build.xcode/mscore/Debug/mscore.app/Contents/Resources/manual/doc_en.qhc>
cannot setup data for help engine: Cannot open collection file: /Users/jimka/MuseScore/build.xcode/mscore/Debug/mscore.app/Contents/Resources/manual/doc_en.qhc
QSslSocket: cannot resolve TLSv1_1_client_method
QSslSocket: cannot resolve TLSv1_2_client_method
QSslSocket: cannot resolve TLSv1_1_server_method
QSslSocket: cannot resolve TLSv1_2_server_method
QSslSocket: cannot resolve SSL_select_next_proto
QSslSocket: cannot resolve SSL_CTX_set_next_proto_select_cb
QSslSocket: cannot resolve SSL_get0_next_proto_negotiated
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
2015-05-12 12:08:33.384 mscore[32958:1273991] Error loading /Library/Internet Plug-Ins/QuickTime Plugin.plugin/Contents/MacOS/QuickTime Plugin:  dlopen(/Library/Internet Plug-Ins/QuickTime Plugin.plugin/Contents/MacOS/QuickTime Plugin, 265): no suitable image found.  Did find:
        /Library/Internet Plug-Ins/QuickTime Plugin.plugin/Contents/MacOS/QuickTime Plugin: mach-o, but wrong architecture
2015-05-12 12:08:33.398 mscore[32958:1273991] Error loading /Users/jimka/Library/Internet Plug-Ins/Google Earth Web Plug-in.plugin/Contents/MacOS/libnpgeplugin.dylib:  dlopen(/Users/jimka/Library/Internet Plug-Ins/Google Earth Web Plug-in.plugin/Contents/MacOS/libnpgeplugin.dylib, 265): no suitable image found.  Did find:
        /Users/jimka/Library/Internet Plug-Ins/Google Earth Web Plug-in.plugin/Contents/MacOS/libnpgeplugin.dylib: mach-o, but wrong architecture
Ignore SSL error: 11 The issuer certificate of a locally looked up certificate could not be found
Ignore SSL error: 17 The root CA certificate is not trusted for this purpose
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
Reply | Threaded
Open this post in threaded view
|

Re: strange error compiling/running musescore

lasconic
Administrator
These are all warnings at startup. So runtime. They are only displayed if the user runs MuseScore from the command line.

Some are qDebug() statements from MuseScore code itself (initscorefonts, initHelp). 

Others are warning messages from Qt (like QSslSocket, Qt loads system ssl libs dynamically and try to find functions, output a warning if it can't find it). 

Others are from Qt Webkit, like the plugins ones. QuickTime, Google earth are plugins you installed in your browser, when Qt Webkit is loaded for the StartCenter, it tries to load the browser plugins from your system and sometimes it fails, thus the warnings. There is currently no way to disable this automatic plugin loading see https://bugreports.qt.io/browse/QTBUG-36349  and https://musescore.org/en/node/52316#comment-271521


lasconic


2015-05-12 12:11 GMT+02:00 Jim Newton <[hidden email]>:
I'm compiling and running musescore from xcode, so admittedly I don't 100%
understand which messages occur at compile time vs runtime.  But I get the
following errors very often.  I don't think it is serious because everything
seems to work fine.  But can someone shed light on what the problems are,
what's causing are, and what I might to to fix them?

initScoreFonts 0x1084536d0
in stat: : No such file or directory
in stat: : No such file or directory
in stat: : No such file or directory
in stat: : No such file or directory
Init midi driver failed
init Help from:
</Users/jimka/MuseScore/build.xcode/mscore/Debug/mscore.app/Contents/Resources/manual/doc_en.qhc>
cannot setup data for help engine: Cannot open collection file:
/Users/jimka/MuseScore/build.xcode/mscore/Debug/mscore.app/Contents/Resources/manual/doc_en.qhc
QSslSocket: cannot resolve TLSv1_1_client_method
QSslSocket: cannot resolve TLSv1_2_client_method
QSslSocket: cannot resolve TLSv1_1_server_method
QSslSocket: cannot resolve TLSv1_2_server_method
QSslSocket: cannot resolve SSL_select_next_proto
QSslSocket: cannot resolve SSL_CTX_set_next_proto_select_cb
QSslSocket: cannot resolve SSL_get0_next_proto_negotiated
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated
2015-05-12 12:08:33.384 mscore[32958:1273991] Error loading
/Library/Internet Plug-Ins/QuickTime Plugin.plugin/Contents/MacOS/QuickTime
Plugin:  dlopen(/Library/Internet Plug-Ins/QuickTime
Plugin.plugin/Contents/MacOS/QuickTime Plugin, 265): no suitable image
found.  Did find:
        /Library/Internet Plug-Ins/QuickTime Plugin.plugin/Contents/MacOS/QuickTime
Plugin: mach-o, but wrong architecture
2015-05-12 12:08:33.398 mscore[32958:1273991] Error loading
/Users/jimka/Library/Internet Plug-Ins/Google Earth Web
Plug-in.plugin/Contents/MacOS/libnpgeplugin.dylib:
dlopen(/Users/jimka/Library/Internet Plug-Ins/Google Earth Web
Plug-in.plugin/Contents/MacOS/libnpgeplugin.dylib, 265): no suitable image
found.  Did find:
        /Users/jimka/Library/Internet Plug-Ins/Google Earth Web
Plug-in.plugin/Contents/MacOS/libnpgeplugin.dylib: mach-o, but wrong
architecture
Ignore SSL error: 11 The issuer certificate of a locally looked up
certificate could not be found
Ignore SSL error: 17 The root CA certificate is not trusted for this purpose
QSslSocket: cannot call unresolved function SSL_get0_next_proto_negotiated



--
View this message in context: http://dev-list.musescore.org/strange-error-compiling-running-musescore-tp7579335.html
Sent from the MuseScore Developer mailing list archive at Nabble.com.

------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Mscore-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mscore-developer


------------------------------------------------------------------------------
One dashboard for servers and applications across Physical-Virtual-Cloud
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
http://ad.doubleclick.net/ddm/clk/290420510;117567292;y
_______________________________________________
Mscore-developer mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/mscore-developer